[Udpcast] Network card Error

Alain Knaff alain at knaff.lu
Tue Sep 23 23:01:43 CEST 2008

Darin MacLachlan wrote:
> This was working and now it has stopped.
> Have a UDPcast server running on a HP DL360G5 with 4 NICS.  One  
> connected to an internal infrastructure (eth2) and another connected  
> to a dedicated switch with the client systems on the same switch (eth3).
> When i run the UDPcast send or receive, using the following command:
> udp-sender -f /home/base.udpc --interface eth3 --point-to-point --full- 
> duplex --max-bitrate 600m --nokbd --portbase=9922 --min-receivers 1  -- 
> rexmit-hello-interval 5000 --max-wait 300
> I get the following error message:
> Udp-sender 2007-03-23
> No suitable network interface found
> The following interfaces are available:
> 	lo
> 	eth2
> 	eth2:1
> Interestingly, an ifconfig show eth3 as a valid network adapter, but  
> the udp-sender does not see the device.  This was working last week,  
> and nothing has changed on the server
> I have tried everything, restarting DHCP, removing the interface and  
> adding again.  Rebooted the server, restarted the network stack  
> manually.  nothing seems to help.
> Using SUSE linux 10 as the base server OS.

You can only use a network card if an address is associated to it. Is
this the case? If so, which address does it have?

Could you also try running udp-sender under strace and send me the output?



More information about the Udpcast mailing list