[Udpcast] Serious Bug - block size too small

Alain Knaff alain at knaff.lu
Fri Jun 22 18:21:35 CEST 2007


Devin Bayer wrote:
> Hello.  I have been using udpcast (version 2006-09-15) successfully  
> until last week when I decided to upgrade.  I first tried 2007-06-02,  
> but that didn't work.  So I tried 2007-03-26 and that failed in the  
> same way.
> 
> When I use either of these newer images I see this message on the  
> receiver:
> 
> 	...
> 	sending go signal
> 	lzop: <stdin>: block size too small -- recompile lzop
> 	bytes=                       848 848 (43.00 Mbps)

There was a bad define in lzop, which made it fail on certain inputs.
The bug has been there for ages, but as it only occurs on certain inputs 
(and never with archives generated with udpcast's busybox itself), it went 
unnoticed for so long.

This is fixed now (version 20070622)

(However, due to the nature of the problem, the new version *may* now 
produce archives which are unusable by the old version)

Regards,

Alain




More information about the Udpcast mailing list