[Udpcast] Boot Disk to Mounted Udpcast

Michael D. Setzer II mikes at kuentos.guam.net
Sun May 7 23:15:31 CEST 2006


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 7 May 2006 at 12:30, Mark Caldwell Walker wrote:

Date sent:      	Sun, 07 May 2006 12:30:00 -0400
From:           	Mark Caldwell Walker <marwalk at marwalk.com>
To:             	Udpcast list <udpcast at udpcast.linux.lu>
Subject:        	[Udpcast] Boot Disk to Mounted Udpcast

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> I've had excellent repeated success with the Udpcast boot disks imaging
> physical drives between computers as long as there is only one hard
> drive on the IDE chain on each machine.  I've backed-up and restored
> numerous times with different systems.  This is fine except I want to
> keep my backups as image files on a larger volume.
> 
> I have not been successful getting the udp-receiver executed on Fedora
> Core 5 on the target machine to play with udp-sender from the boot disk
> on a notebook I want to back up.  I'm hoping to use the Fedora machine
> to back up and restore several other machines on my network to a new
> 250GB drive mounted on the Fedora box.
> 
> On the notebook (or any machine to be backed up) I boot from the Udpcast
> boot CD and manually set the IP address.  I take the default values for
> everything else, except I select no compression.  I then start
> udp-sender on the CD-booted machine.  It executes with the normal
> broadcast messages.
> 
> Then I go to the Fedora machine and execute the following:
> "udp-receiver --file <path/file.img> --log <path/file.log>" and press
> enter.  The sender machine immediately acknowledges and establishes a
> connection with the receiver machine.  The sender machine displays the
> "Press any key to start" message, but udp-receiver on the Fedora machine
> shows nothing in response.  The receiver machine (Fedora box) appears to
> sit idle as if it is not getting something it needs; there is no "Press
> any key to start" message on the receiver machine.  If I hit a key on
> the sender machine anyway to get it started it starts transmitting but
> promptly starts displaying timeout lines and eventually quits.  After
> killing the receiver with CTRL-C, two empty files, <path/file.img> and
> <path/file.log> are on the target volume.  There is nothing in those
> files, even when viewed with a hex editor.  I have observed that the two
> systems are using different multicast addresses, but they still find
> each other.
> 

You might be having a problem with the selinux/firewall. You could try to use 
system-config-securitylevel or System / Admiistration /  Securitylevel and 
Firewall. Then add port 9000 and 9001 to the ports allowed. It's been a while 
since I used udpcast from fedora core 1 machine, but I recall it was these 
changes that I needed to make.

In my configuration, I use udpcast to image the other 19 machines in my lab, 
but use g4l to create images on my fedora core 3 system with two 250GB 
drives. G4l creates images that work with udpcast directly as well, (at least 
I've done it in the past, dd | compression | ftp). Problem I had was my MIS 
department has the dhcpd setup with 4 class c networks on the physical 
network, and classroom machines would get IPs on 3 of the different IP 
blocks, and udpcast would only work to machines on the same class C. So I 
image one machine in the classroom, and then use a boot diskette that 
gives each machine a private 10.0.0.x number, and then image them with 
udpcast. 

G4l uses dd to copy the image, and can use gzip, lzop, bzip or no 
compression. I generally use lzop since it about twice as fast to create the 
image on my P4 machines, but does make the image about 10% or so 
larger than gzip, but 1 hour versus 2 hours is more important to me. The 
restore speed is almost the same. 






> I have scoured the man pages of both udp-receiver and udp-sender, and
> experimented with several Udpcast switch combinations to no avail.  I've
> tried --nosync, --broadcast,  --mcast-all-addr, --mcast-rdv-address
> (which crashed the sender and displayed a SIG message), --nokbd,
> - --autostart 50, --ttl 1, --rexmit-hello-interval 1000,
> - --retries-until-drop 100 (which also crashed the sender and displayed a
> SIG message), --point-to-point, and -b 1024.  Nothing changed from any
> of that; udp-receiver never provides a "Press any key to start" message,
> even after the sender recognizes the established connection and displays
> the "Press any key to start" message.
> 
> I also tried booting the receiving machine from the Udpcast boot CD and
> trying the --file <path/file.img> option there, but it just seemed to
> transfer a physical copy of the /boot folder from the sending machine.
> So, I repartitioned the target drive and am hoping there is some way to
> make Udpcast work in my configuration by writing physical images of the
> source drives to logical image files on the target drive.  And,
> naturally, I would like to restore from image files on the storage
> volume mounted on the Fedora machine to physical disks on the target
> machines.
> 
> Help.
> 
> Thanks,
> Mark
> 
> - --
> 
> Mark Caldwell Walker
> GnuPG public key is available at
> http://www.earthalien.com/#pubkey
> 
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.2.2 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
> 
> iD8DBQFEXiCI0+BEGmqt+LYRApfKAJ4xOYuEMYfQQDpwVLNnAsPzilOB7wCfWC+o
> Jcwl25i3maUvlwSMi8h/KfQ=
> =9XiK
> -----END PGP SIGNATURE-----
> _______________________________________________
> Udpcast mailing list
> Udpcast at udpcast.linux.lu
> https://lll.lgl.lu/mailman/listinfo/udpcast
> 


+----------------------------------------------------------+
  Michael D. Setzer II -  Computer Science Instructor      
  Guam Community College  Computer Center                  
  mailto:mikes at kuentos.guam.net                            
  mailto:msetzerii at gmail.com
  http://www.guam.net/home/mikes
  Guam - Where America's Day Begins                        
+----------------------------------------------------------+

http://setiathome.berkeley.edu
Number of Seti Units Returned:  19,471
Processing time:  32 years, 290 days, 12 hours, 58 minutes
(Total Hours: 287,489)


BOINC Seti at Home Total Credits 827636.909386 


-----BEGIN PGP SIGNATURE-----
Version: PGP 6.5.8 -- QDPGP 2.61c
Comment: http://community.wow.net/grt/qdpgp.html

iQA/AwUBRF3W1CzGQcr/2AKZEQIzeACfRJS56q3v3z/IT4zi0QR0o0a3puMAoNhY
Y/XK3h7khOqbrN3tr9CvUGRW
=PJBZ
-----END PGP SIGNATURE-----




More information about the Udpcast mailing list