[Udpcast] Boot Disk to Mounted Udpcast

Mark Caldwell Walker marwalk at marwalk.com
Sun May 7 18:30:00 CEST 2006


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I've had excellent repeated success with the Udpcast boot disks imaging
physical drives between computers as long as there is only one hard
drive on the IDE chain on each machine.  I've backed-up and restored
numerous times with different systems.  This is fine except I want to
keep my backups as image files on a larger volume.

I have not been successful getting the udp-receiver executed on Fedora
Core 5 on the target machine to play with udp-sender from the boot disk
on a notebook I want to back up.  I'm hoping to use the Fedora machine
to back up and restore several other machines on my network to a new
250GB drive mounted on the Fedora box.

On the notebook (or any machine to be backed up) I boot from the Udpcast
boot CD and manually set the IP address.  I take the default values for
everything else, except I select no compression.  I then start
udp-sender on the CD-booted machine.  It executes with the normal
broadcast messages.

Then I go to the Fedora machine and execute the following:
"udp-receiver --file <path/file.img> --log <path/file.log>" and press
enter.  The sender machine immediately acknowledges and establishes a
connection with the receiver machine.  The sender machine displays the
"Press any key to start" message, but udp-receiver on the Fedora machine
shows nothing in response.  The receiver machine (Fedora box) appears to
sit idle as if it is not getting something it needs; there is no "Press
any key to start" message on the receiver machine.  If I hit a key on
the sender machine anyway to get it started it starts transmitting but
promptly starts displaying timeout lines and eventually quits.  After
killing the receiver with CTRL-C, two empty files, <path/file.img> and
<path/file.log> are on the target volume.  There is nothing in those
files, even when viewed with a hex editor.  I have observed that the two
systems are using different multicast addresses, but they still find
each other.

I have scoured the man pages of both udp-receiver and udp-sender, and
experimented with several Udpcast switch combinations to no avail.  I've
tried --nosync, --broadcast,  --mcast-all-addr, --mcast-rdv-address
(which crashed the sender and displayed a SIG message), --nokbd,
- --autostart 50, --ttl 1, --rexmit-hello-interval 1000,
- --retries-until-drop 100 (which also crashed the sender and displayed a
SIG message), --point-to-point, and -b 1024.  Nothing changed from any
of that; udp-receiver never provides a "Press any key to start" message,
even after the sender recognizes the established connection and displays
the "Press any key to start" message.

I also tried booting the receiving machine from the Udpcast boot CD and
trying the --file <path/file.img> option there, but it just seemed to
transfer a physical copy of the /boot folder from the sending machine.
So, I repartitioned the target drive and am hoping there is some way to
make Udpcast work in my configuration by writing physical images of the
source drives to logical image files on the target drive.  And,
naturally, I would like to restore from image files on the storage
volume mounted on the Fedora machine to physical disks on the target
machines.

Help.

Thanks,
Mark

- --

Mark Caldwell Walker
GnuPG public key is available at
http://www.earthalien.com/#pubkey


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFEXiCI0+BEGmqt+LYRApfKAJ4xOYuEMYfQQDpwVLNnAsPzilOB7wCfWC+o
Jcwl25i3maUvlwSMi8h/KfQ=
=9XiK
-----END PGP SIGNATURE-----



More information about the Udpcast mailing list