[Udpcast] making a custom boot disk

Alain Knaff alain at knaff.lu
Thu Oct 2 21:20:28 CEST 2003

On Thursday 02 October 2003 21:07, you wrote:
> Alain Knaff wrote:
> > Could you check with mdir a: which files are on the floppy?
> -rwxr--r--   root    12624   ldlinux.sys*
> -rwxr--r--   root  644137   linux*
> -rwxr--r--   root         80   syslinux*
> This leaves me with 781K available. I didn't notice it before, but when
> I run the ./makeImage -t net-mod.tar.gz -k
> /usr/src/linux-2.4.21/arch/i386/boot/bzImage -f /dev/fd0 I get "Disk
> full".  Although, I still have space on the floppy I guess it's not
> enough for initrd?

Yes, it looks indeed as if it this is not enough for initrd. Try only
including those modules that you actually need into the initrd in
order to get a smaller initrd (with the --modules flag). Without
--modules, a default selection is picked which may not fit, because
your kernel is slightly larger than the default.

> Alain Knaff wrote:
> > In that case, could you just once try with the pre-
> > compiled kernel. This step will allow me to find out whether
> >it is a problem
> > with the kernel or with the makeImage script.
> # ./makeImage -t net-mod.tar.gz -k
> /lib/modules/2.4.21-udpcast/build/arch/i386/boot/bzImage -f /dev/fd0
> I get the same exact output as when I run the makeImage.  Disk full.
> The files are the exact same size also.

The default kernel supports bzip2-compressed initrds. Activate this
with the --bzip2 flag; this will make it small enough to fit.

> When I run the makeImage for the precompiled kernel, am I pointing to
> the wrong bzImage?  I get the feeling that I'm not using the makeImage
> command with the precompiled image correctly.

The canonical name of the precompiled image, is
/boot/vmlinuz-2.4.21-udpcast , but I just noticed that indeed there is
an exact copy in
/lib/modules/2.4.21-udpcast/build/arch/i386/boot/bzImage as well.

So the reason why it didn't fit is the abscence of the --bzip2 flag


More information about the Udpcast mailing list