[Udpcast] making a custom boot disk

Alain Knaff alain.knaff at lll.lu
Thu Oct 2 01:22:29 CEST 2003

On Thursday 02 October 2003 00:25, Eric Becker wrote:
> Well, the PC that had the 2.4.20-20.9 kernel got hosed and I had to
> reinstall.  It was a RH 9 install that had been updated.
> I installed this time with a Mandrake 9.1 distro.  I installed the
> udpcast rpm and the kernel-udpcast rpm.  I then downloaded the 2.4.21
> kernel from ftp.kernel.org and extracted it into /usr/src/linux-2.4.21/.
>  Then I copied the udpc-config.txt file into that dir and called it
> .config.  Then I edited the the Makefile and put in the -udpcast.  I
> then did a "make oldconfig" which ran fine.  I also did the make dep &&
> make bzImage && make modules && make modules_install and they all ran
> fine.  Then I ran ./makeImage -t net-mod.tar.gz -k
> /usr/src/linux-2.4.21/arch/i386/boot/bzImage  -f /dev/fd0 which seemed
> to run ok.  I tried to boot off of the floppy and I get:
> Could not find ramdisk image: initrd
> boot:

For some reason, apparently the initrd got not copied to floppy / or a
corrupted initrd got copied to floppy.

Could you check with mdir a: which files are on the floppy?

If the initrd _is_ present, it means that for some reason it is
corrupt (or that the kernel cannot figure out how to access it)

In that case, could you just once try with the pre-compiled
kernel. This step will allow me to find out whether it is a problem
with the kernel or with the makeImage script. (The pre-compiled kernel
might be unable to handle your card (unless it is a Tigon 3 card); but
this step will help us find out why the initrd cannot be found. Once
we solved the initrd problem, we can continue again with
custom-compiled kernels)

Oh, and btw http://www.netmeister.org/news/learn2quote.html



More information about the Udpcast mailing list