[Udpcast] making a custom boot disk

Eric Becker Eric.Becker at wwt.com
Thu Oct 2 00:25:19 CEST 2003

Well, the PC that had the 2.4.20-20.9 kernel got hosed and I had to
reinstall.  It was a RH 9 install that had been updated.  

I installed this time with a Mandrake 9.1 distro.  I installed the
udpcast rpm and the kernel-udpcast rpm.  I then downloaded the 2.4.21
kernel from ftp.kernel.org and extracted it into /usr/src/linux-2.4.21/.
 Then I copied the udpc-config.txt file into that dir and called it
.config.  Then I edited the the Makefile and put in the -udpcast.  I
then did a "make oldconfig" which ran fine.  I also did the make dep &&
make bzImage && make modules && make modules_install and they all ran
fine.  Then I ran ./makeImage -t net-mod.tar.gz -k
/usr/src/linux-2.4.21/arch/i386/boot/bzImage  -f /dev/fd0 which seemed
to run ok.  I tried to boot off of the floppy and I get:

Could not find ramdisk image: initrd

I've obviously missed something...what am I forgetting to do?

I have compiled the network card module, but haven't tried to build it
into the kernel yet.  I'd like to get a working boot disk before I try
and make it hit the network.  

>>> alain.knaff at lll.lu 09/30/03 18:09 PM >>>
On Tuesday 30 September 2003 23:58, Eric Becker wrote:
> I have some hp pc's that I'm trying to udpcast.  They have broadcom
> netxtreme network cards which don't seem to be supported by the
> boot disk, nor by the net-mod.tar.gz secondary floppy.
> I followed the directions here
> http://udpcast.linux.lu/current/makeImage.html#kernelCompile on making
> custom boot disk by compiling my own kernel.
> Before doing anything I edited the Makefile and changed the
> "extra-version" parameter.  I just deleted what was there and put in
> "-udpcast".  I do a cd /usr/src/linux/2.4.20-20.9.  Then I copy the
> udpc-config.txt file to this dir and name it .config.  Next I do a
> oldconfig" which runs fine and so does the "make dep".  However; when
> do a "make bzImage" it runs for a while and then it stops with errors
> regarding devfs?  What am I doing wrong?

Could you post the exact error messages?

Also, are you sure that this is an original kernel (as distributed by
ftp.kernel.org). Indeed, the version number (2.4.20-20.9) strikes me
as somewhat odd...

> I even tried to download the RPM with a pre-compiled kernel and its
> modules, but I'm unsure what do with it.

Just install it with rpm -i , and then run makeImage

Or, alternatively, use the online image generator at

>  Can someone please point me in
> the right direction?  All I need is a boot disk with the Broadcom
> drivers that gets me udpcasting.

Not sure whether the necessary module is in the pre-compiled kernel.

If not, try getting kernel sources from ftp.kernel.org, and compile
from these


More information about the Udpcast mailing list